Tracking202 on Youtube
Solution: Mac Keyboard input not working on AWS Workspaces

Most of my dev work is done on my Mac, but every once in a while I need to check out stuff on a PC or from another computer. For that I use Amazon Workspaces. This is also a great solution for foreign affiliates that need a US based ip and machine for testing geo restricted offers.

A few days ago keyboard input stopped working. I rebooted the server and my laptop multiple times, installed a new client, rebuilt the server and still nothing worked.

Finally today, I searched online to see if this was something others were experiencing, and found out I wasn't alone. From my research it looks like it's a problem in Os X.

For me, the fix for this was quick and easy. Here's the thread where I found my fix. It worked on Os X Yosemite 10.10.4 even though the thread talks about Mavericks 10.9

The command I used in the terminal was the following:

sudo sysctl -w > /dev/null 2>&1

After that, everything started working correctly without a reboot of any sort. The highlighted fix on this page included extra stuff that I didn't use. So if this command doesn't work for you, also try the highlighted fix. I also suspect that doing this in the terminal is not permanent and will need to be done again after a reboot. To make it more permanent you may have to enter this link into you /etc/sysctl.conf file.

I thought I'd share it here, because it could save you a few hours or days of searching. Additionally, it's part of my new effort to learn something new and teach what I learn every day.